Informática, Linux, Software, Tutoriales, Ubuntu

Instalar Canon pixma iP1700 en Ubuntu

Este manual es la actualización de uno que ya había realizado anteriormente. Para quienes ya han visto el antiguo manual, se darán cuenta que faltan opciones como por ejemplo para imprimir en modo borrador, o el problema de que las impresiones no salían tal como aparecen en pantalla.  Hoy vamos a solucionar todos estos problemas. Ahora les enseñare más opciones para que podamos sacar el máximo provecho de nuestra impresora Canon Pixma iP1700 en Ubuntu.  Por cierto, el tutorial no funciona para arquitecturas AMD64.

Pasos previos
  • Lo primero que tenemos que hacer es conectar y encender nuestra impresora.
  • Después de esto abrimos un Terminal (Aplicaciones→Accesorios→Terminal) e instalamos el software básico de compilación, el cual es necesario si deseamos instalar algún paquete y solo tenemos el código fuente. Ejecutamos lo siguiente (Recuerda que el Terminal antes de instalar un paquete siempre te preguntara si deseas continuar, en todos los pasos das que “Si”):

sudo aptitude install build-essential

  • Actualizamos los paquetes escribiendo:

sudo apt-get update

  • Ahora tenemos que instalar el paquete que nos ayudara a convertir los archivos binarios a .deb y algunas librerías necesarias.  Escribimos lo siguiente:

sudo apt-get install alien libxml1 libpng12-0 libpng12-dev libgtk1.2 libgtk1.2-common

  • Es momento de descargar los drivers de la impresora.  Para propósitos de este tutorial vamos a asumir que te encuentras en el directorio /home/tu-nombre/obux.  Los drivers que vamos a utilizar son los de la impresora iP2200, por lo cual escribimos en un terminal :

mkdir obux
cd obux
wget http://software.canon-europe.com/files/soft24301/software/iP2200_Linux_260.tar.gz

  • Después de descargar el archivo lo descomprimimos escribiendo la siguiente instrucción:

tar -xvzf iP2200_Linux_260.tar.gz

  • Ahora convertimos los paquetes RPM a paquetes especiales para Ubuntu, osea a paquetes DEB (Fue por ello que al inicio instalamos la utilidad Alien):

sudo alien cnijfilter-common-2.60-1.i386.rpm cnijfilter-ip2200-2.60-1.i386.rpm

Instalando nuestra impresora ip1700
  • Bueno, después de tanto paso previo procedemos a instalar los archivos que generamos para lo cual tecleamos en el terminal:

sudo dpkg -i *.deb

  • Ahora creamos los enlaces simbólicos para las librerías por si estos no funcionan de manera correcta. Esto es debido a que el archivo libtiff.so.3 es una versión antigua y es la que utiliza el driver que instalamos, por lo cual para corregirlo escribimos:

sudo ln -s /usr/lib/libtiff.so.4 /usr/lib/libtiff.so.3
sudo ln -s /usr/lib/libpng.so /usr/lib/libpng.so.3
sudo ln -s /usr/lib/libxml2.so.2 /usr/lib/libxml.so.1

  • Ahora hacemos que el sistema se de cuenta de los cambios hechos:

sudo ldconfig

  • También reiniciamos Cups (El sistema que administra las impresoras en Linux)

sudo /etc/init.d/cupsys restart

  • Por ultimo añadimos la nueva impresora.  Nos vamos a Sistema→Administración→Impresoras. Si ya nos aparece una impresora con el nombre iP1700 la borramos (Ya que el sistema la detecto al inicio pero no la instalo).
  • Ahora damos clic en “Impresora Nueva” y seleccionamos la opción “Canon iP1700 USB #1” y damos clic en “Adelante”.
  • Ahora damos clic en la opción “Proporciona Archivo PPD” y se activara una opción donde dice “Ninguno” Ahí damos clic y nos dirigimos a la siguiente ubicación: /usr/share/cups/model/
  • Ya estando allí seleccionamos el driver canonip2200.ppd.
  • Ahora damos clic en “Adelante” y por ultimo damos clic en “Aplicar”.
adiendo opciones de calidad de impresión
  • Desafortunadamente, el archivo que instalamos no contiene información sobre calidad de impresión para la pixma ip1700. Para solucionar esto y añadir opciones de impresión en Borrador, Standard, Normal, etc simplemente tecleamos en un terminal:

gksudo gedit /etc/cups/ppd/iP1700.ppd

  • Después de la sección “Resolution” añadimos las siguientes lineas:

*OpenUI *CNQuality/Quality: PickOne
*DefaultCNQuality: 3
*CNQuality 2/High: "2"
*CNQuality 3/Normal: "3"
*CNQuality 4/Standard: "4"
*CNQuality 5/Economy: "5"
*CloseUI: *CNQuality

Aumentar la Resolución DPI de la impresión
  • Lo siguiente que haremos será añadir una opción para aumentar la resolución de impresión.  En realidad no se si esto afecta la calidad de impresión ya que hice varias pruebas y en todas (según mis análisis) la calidad de la impresión es la misma.  Supuestamente el modelo Pixma iP1700 alcanza una resolución de 4000 DPI. Dentro de la sección “Resolution” añadimos las siguientes lineas:

*Resolution 1200/1200 dpi: "<</HWResolution[1200 1200]>>setpagedevice"
*Resolution 2400/2400 dpi: "<</HWResolution[2400 2400]>>setpagedevice"
*Resolution 4800/4800 dpi: "<</HWResolution[4800 4800]>>setpagedevice"

  • Después de esto, reiniciamos cups para que se hagan efectivos los cambios:

sudo /etc/init.d/cupsys restart

  • Para empezar a utilizar y evaluar las distintas calidades de impresión y distintas resoluciones DPI simplemente nos vamos a Sistema→Administración→Impresoras Seleccionamos la iP1700 y damos clic en la pestaña “Opciones de la Impresora“.
Dándole mantenimiento a la ip1700 en Ubuntu
  • Para darle mantenimiento a la impresora, solo tecleamos lo siguiente:

cngpij -P iP1700

  • En la pestaña Mantenimiento, seleccionamos la opción Limpieza o Limpieza a fondo dependiendo de las necesidades.
Impresiones en Papel tamaño carta utilizando Open Office
  • Lo único que falta es configurar la impresora de manera que las impresiones por defecto sean en papel tamaño carta.  Para esto simplemente abrimos el procesador de Textos de Open Office.
  • Nos vamos al menú Formato→Pagina y en la pestaña Página donde dice “Formato” seleccionamos Letter. Damos clic en Aceptar.
  • Ahora guardamos el documento como Plantilla (Menu Archivo→Plantilla→Guardar).
  • Ahora que ya tenemos una plantilla con papel tamaño carta, la establecemos como predeterminada.  Para ello solo nos vamos a Menu Archivo→Plantilla→Administrar, buscamos la plantilla que creamos, le damos clic derecho y seleccionamos la opción “Definir como plantilla predeterminada“.
  • A partir de ahora los nuevos documentos que se crearán, lo harán con los formatos y estilos definidos por nosotros en la plantilla que creamos.

Con esto creo que tenemos funcionando al maximo nuestra impresora Canon Pixma iP1700 en Ubuntu.  Espero que el tutorial haya sido facil de seguir y que me cuentes tu experiencia ubuntera junto a la iP1700.  Saludos amigos!

Anuncios

48 thoughts on “Instalar Canon pixma iP1700 en Ubuntu”

  1. otra forma mas facil de instalar las impresoras en cualquier distro es con turbo print, tiene soporte para muchisimas y tambien para las mas recientes de canon, el unico problema es que es pagado vale 30 dolares 😦

  2. Mil gracias por la publicación. Como soy ignorante en la materia, copié y pegué línea a línea, deseando que sucediera paso a paso todo lo teóricamente previsto. Funcionó una sola vez, imprimí una hoja. Creo que luego fue que intenté cambiar a modo económico y ya no imprimió más. Se me ocurrió recargar el .pod(creo) y funcionó otra vez, así que no puedo respirarle cerca. Esto de Linux tiene demasiadas cosas frustrantes en cuanto a compatibilidades y automatizaciones, para quienes no podemos ponernos a estudiar e investigar cada escollo que se presenta. Ojalá que esta distro siga avanzando en ese sentido, pues el dominio mayoritario del mercado se sustenta en su mayoría por usuarios torpes como yo =)

  3. @ Kr105:
    Como dices lo malo de turboprintt es el precio….

    @ Billy:
    Jajaja, tienes mucha razón. Yo creo que en cada nueva versión de Ubuntu se trata de mejorar en esos aspectos.

    @ Raul:

    Gracias a ti por tu comentario. Saludos!

  4. @ Julio:
    Quiza no éstes manejando bien la ruta (/usr/share/cups/model/) Prueba escribir la anterior ubicación en el Nautilus y mira que te aparece. Supuestamente ahí tendría que estar el archivo .PPD

  5. Ps disculpa, pero no, no aparece la carpeta, y el comando sudo dpkg -i *.deb no funciona, me sale el mensaje: dpkg: error al procesar *.deb (–install):
    no se puede acceder al archivo: No existe el fichero ó directorio
    Se encontraron errores al procesar:
    *.deb

    y con la ruta (/usr/share/cups/model/) aparece que no existe,
    Disculpa,

  6. @ Julio:
    Mira con lo del sudo dpkg .deb si no funciona es porque no fueron generados los archivos deb, deberías de verificar los pasos anteriores a este punto. Y con respecto a la Ruta, ¿Que es lo que dice el error? Quiza no te haz dado cuenta, pero esa ruta es solo la secuencia de carpetas. Para acceder manualmente solo tendrías que ir a “Sistema de Archivos→usr→share→cups→model”.

    Una pregunta ¿Que versión de ubuntu tienes?

  7. Tengo ubuntu 8.04, y con los de las carpetas, al llegar a la carpeta cups, no existe una llamada model, y con los archivos .deb, todos los pasos anteriores fueron realizados correctamente supuestamente.

  8. @ Julio:
    Houston, tenemos un problema!! 🙂
    Bueno amigo, y el procedimiento lo hiciste teniendo encendida tu impresora? Lamento que solo para instalar una impresora tengas que enfrentar estos problemas. Esperemos que el soporte de la versión que sale en octubre haya mejorado un poco.

    Te preguntaba si tenias encendida tu impresora y conectada durante el proceso desde el inicio pues resulta que el mismo sistema te genera supuestamente una impresora ip1700, entonces ahí es cuando también se genera la carpeta cups→model, porque si te das cuenta en ningún paso nosotros generamos esta carpeta.

    Bueno y con lo de que no te aparecen los archivos .deb, si tan traumático y difícil es el caso, yo te puedo enviar los que fueron generados en mi equipo, junto al archivo ppd.

    Como te comentaba, para mi es extraño el error y bueno no se me ocurre de momento otra solución.

  9. Ps, la impresora si està encendida y conectada a la compu, pero en la carpeta cups no me genera model, y creo que si puedes enviarme el archivo ppd, te lo voy a agradecer, esperoo que con eso funcione, gracias de nuevo por la ayuda

  10. @ Jorge Chavez y Javier:
    Los drivers para Windows los pueden encontrar en la pagina de Canon.

    @ Huguin:
    Es posible que estés utilizando otra versión de ubuntu ( por ejemplo la de 64 bits). Si es así parece que existen problemas entre las librerías y están no dejan trabajar a la impresora.

  11. @ Angel:
    Hola, a continuación adjunto el link donde estan los drivers de esa impresora en paquete .deb para Ubuntu 8.04:
    http://www.avasys.jp/lx-bin2/linux_e/spc/DL1.do

    Ahi te preguntan el sistema, la versión, etc y la forma de conexión de la impresora, el paquete se descarga y se le da doble clic y teoricamente la impresora ya tendria que funcionar.

    Si aún hay dudas de como instalar tambien puedes visitar:
    http://ubuntuforum-pt.org/index.php?topic=11715.0 (Solo que es en frances pero casi todo se entiende…)

    Y por ultimo los drivers como “oficiales” para Linux en varias paqueterias (.deb, .rpm, .bin, etc) y la forma de instalarlos (En ingles) Los metodos de instalación de Debian tambien funcionan para Ubuntu:
    http://www.openprinting.org/show_printer.cgi?recnum=Epson-Stylus_TX200

    Saludos!

  12. @ Gualb Dr Q:
    Para ambas. Funciona en Ambas.

    @ Eduardo:
    Saludos a ti amigo y animo con linux, al inicio todo es difícil pero después ya te vuelves todo un experto.

  13. Mil gracias para la información. Agradezco mucho su ayuda!

    Otra pregunta – se puede convertir los archivos ‘i386.rpm’ a ‘.deb’ para computadoras de amd64 usando alien?

  14. Saludos JoseKont, buenisimo tutorial.
    Funciona en LInux Mint Elyssa tambien (obviamente pues esta basada en Ubuntu).
    Lo interesante es que con el otro tutorial no podia imprimir paginas oficio/legal, ahora si.

  15. @ Mateo:

    Si se pueden convertir, pero no se si funcionan. Seria de probar.

    @ Gualb:
    Gracias amigo por tu comentario, que bueno que el tutorial te sea útil, realmente a mi en Ubuntu 8.10 no me funciono, es algo que tengo que revisar estos días. Saludos!

  16. hola lo he intetado de todas manera y no he tenido suerte me sale el siguiente error
    sudo /etc/init.d/cupsys restart
    sudo: /etc/init.d/cupsys: command not found
    por fa digan lo que puedo hacer

    1. mmmm espero ya te hayan respondido, pero qui va:

      Creo que el comando varia de acuerdo a la version de ubuntu,
      porque no pruebas con:
      /etc/init.d/cups restart
      Esto funciono para mi, uso ubuntu 9.04

      1. Carlos, mil gracias, yo tenía el mismo problema, y utilizo Guadalinex 6, que está basado en Ubuntu 9.04, pero al leer tu respuesta, abrí el terminal, introduje el script que tu aportas, y problema solucionado.

  17. josekont:
    Gracias por publicar este tutorial para la instalación de la impresora, me funcionó muy bien en ubuntu 8.04. Pero tampoco me funcionó en ubuntu 8.10 😦
    Estoy a la espera de algún post o comentario sobre que hay que cambiar en el procedimiento para hacer funcionar el driver en esta versión (8.10) de ubuntu.

    Saludos

    DrakerDG

  18. muxa fijenze ke io no pud i la vdd ke weva pro no sabn zi ai otra manera d arreglar sa koza xke la vdd m urge xfa zi konocen otra manera pongala aki xke zi la necesito graziaz

  19. Gracias, funciono super bien.

    Oye, deberias crear como un driver y solicitar actualizar la base de drivers de canoon en ubuntu. Asi las siguientes versiones ya no tengamos que hacer este trabajo.

  20. Me gustaria que se me ayudara a bajar un driver para canon pixma ip 1700. Mi computadora no tiene CD ROOM para colocar el CD de instalacion y no puedo utilizar la impresora. Estoy consado de buscar opciones como bajar gratis el driver y no lo logro.

    Ayudenme por favor.

    1. @Tairon:

      Debes ingresar al sitio de Canon y ellos tienen el driver para descargarlo. No es complicado, solo es de buscar.

      Saludos.

  21. por mas que intente , no pude instalar mi impresora . es una canon pixma ip 1700/ ip 1300 …les gradeceria demasiado si me explicaran mas detalladamente como hacerlo o buscar una alternativa mas fasil..pos sorry pero no me unciono…se los agradesco de sobremanera pero creo que mori en el intento.

  22. Hola !! yo soy nueva trabajando con todo esto de linux , eh seguido los pasos q mencionas anteriormente pro cuando voy por el 3er. paso me sale lo siguiente
    chavarria@ANAYVICKY:~/obux$ sudo apt-get install alien libxml1 libpng12-0 libpng12-dev libgtk1.2 libgtk1.2-common
    Leyendo lista de paquetes… Hecho
    Creando árbol de dependencias
    Leyendo la información de estado… Hecho
    alien ya está en su versión más reciente.
    E: No se pudo encontrar el paquete libxml1

    porfavor AYUDENME !!!
    gracias de antemano

  23. haciendo los procediminetos me sale un error y dice q no encuentra el paquete
    libxml1 de ahi no paso q me recomiendan xfa soy un novato

  24. Señores, disculpe que les escriba
    pero ya hice todos pasos y a mi no me genera
    el archivo canonip2200.ppd
    en la carpeta/usr/share/cups/model/

    Alguien me puede ayudar

    Gracias!

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s